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LỜI GIỚI THIỆU 

 

Nhằm góp phần làm phong phú nguồn tư liệu phục vụ nghiên cứu, học tập cho bạn 

đọc trong ngành chăn nuôi, Nhà xuất bản Đại học Cần Thơ xin được phép ấn hành và 

giới thiệu cùng bạn đọc giáo trình “Tin học ứng dụng trong chăn nuôi và thú y” do 

PGS.TS. Nguyễn Trọng Ngữ, TS. Nguyễn Thị Hồng Nhân và TS. Nguyễn Văn Hớn 

biên soạn.  

Giáo trình bao gồm 04 chương, trong đó mỗi chương trình bày những nội dung lý 

thuyết căn bản và các bài tập để ứng dụng cụ thể. Chương 1 giới thiệu về phần mềm 

Minitab như lập bảng tính, truy xuất kết quả thống kê và quản lý dữ liệu. Chương 2 trình 

bày các khái niệm về thống kê và việc ứng dụng Minitab trong phân tích thống kê mô 

tả. Chương 3 nói về áp dụng Minitab trong phân tích phương sai. Chương 4 hướng dẫn 

phân tích hồi quy và tương quan với mô hình hồi quy tuyến tính đơn giản và hồi quy 

tuyến tính đa tham số. 

Nhà xuất bản Đại học Cần Thơ chân thành cám ơn các tác giả và sự đóng góp ý 

kiến của quý thầy cô trong Hội đồng thẩm định Trường Đại học Cần Thơ để giáo trình 

“Tin học ứng dụng trong chăn nuôi và thú y” được ra mắt bạn đọc.  

Nhà xuất bản Đại học Cần Thơ trân trọng giới thiệu đến giảng viên, sinh viên và 

bạn đọc giáo trình này.  

NHÀ XUẤT BẢN ĐẠI HỌC CẦN THƠ 

  



 

 

 

 



 

 

LỜI NÓI ĐẦU 

 

Ngày nay tin học được ứng dụng rộng rãi trong hầu hết tất cả các lĩnh vực. Đối với 

công tác nghiên cứu khoa học nói chung, và nghiên cứu khoa học trong lĩnh vực chăn 

nuôi và thú y, thì việc xử lý số liệu là bước cần thiết để có được các kết quả đáng tin cậy 

và từ đó có thể rút ra được những kết luận quan trọng liên quan đến nghiên cứu. Khối 

công việc này thường bắt đầu bằng việc nhập và xử lý số liệu thô trên phần mềm Excel, 

sau đó chuyển sang phần mềm chuyên dụng để xử lý thống kê. Khối kiến thức tin học 

đại cương, bao gồm việc sử dụng Excel, sinh viên được học trong những học phần 

chuyên ngành khác. Đối với giáo trình hiện tại, nội dung tập trung chủ yếu vào việc giới 

thiệu và hướng dẫn sử dụng phần mềm thống kê Minitab 16.0 trong xử lý các số liệu 

khoa học liên quan đến chuyên ngành Chăn nuôi và Thú y. 

Giáo trình có 4 chương, trong đó mỗi chương trình bày những nội dung lý thuyết 

căn bản và tiếp theo là các bài tập để ứng dụng cụ thể. Chương 1 giúp người học nắm 

bắt được các thao tác liên quan đến phần mềm Minitab như lập bảng tính, truy xuất kết 

quả thống kê và quản lý dữ liệu. Chương 2 trình bày các khái niệm về thống kê và việc 

ứng dụng Minitab trong phân tích thống kê mô tả và kiểm định giả thuyết. Phân tích 

phương sai là nội dung chủ yếu của Chương 3, tập trung vào các kiểu bố trí hoàn toàn 

ngẫu nhiên, khối hoàn toàn ngẫu nhiên, hình vuông Latin và phân tích thừa số. Chương 

4 hướng dẫn phân tích hồi quy và tương quan với mô hình hồi quy tuyến tính đơn giản 

và hồi quy tuyến tính đa tham số. 

Trong quá trình biên soạn, chúng tôi đã nhận được những ý kiến đóng góp quý báu 

của các đồng nghiệp. Mặc dù đã có nhiều cố gắng, tuy nhiên giáo trình có thể vẫn còn 

nhiều chỗ sai sót, chúng tôi mong nhận được sự góp ý của tất cả quí bạn đọc. 

Xin chân thành cảm ơn. 

NHÓM TÁC GIẢ 
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Chương 1 

GIỚI THIỆU PHẦN MỀM MINITAB 

 

1.1 SỬ DỤNG MINITAB 

Giáo trình này chỉ giới thiệu về Minitab for Windows để sử dụng minh họa cho 

các bài tập. Nếu sử dụng các phiên bản khác của Minitab thì có thể nó sẽ không hỗ trợ 

một số công cụ và giao diện khác so với giáo trình.  

 

Minitab là phần mềm chuyên dụng về thống kê, rất tiện lợi trong xử lý số liệu và 

phân tích thống kê, được sử dụng rộng rãi phục vụ nghiên cứu khoa học trong nhiều lĩnh 

vực, đặc biệt trong nông nghiệp và sinh học. Phần mềm này giúp hiểu biết thêm về thống 

kê và tiết kiệm thời gian tính toán và ban đầu được thiết kế để phục vụ việc giảng dạy 

môn thống kê, sau đó đã được phát triển thành công cụ phân tích và trình bày dữ liệu rất 

hữu hiệu. 

Giao diện Minitab cho phép gõ các câu lệnh trong cửa sổ thao tác (Session Window) 

và thực thi chương trình bằng cách chọn lệnh từ thanh Menu và điền đầy đủ yêu cầu vào 

các hộp hội thoại. Các câu lệnh và kết quả sẽ được thể hiện ở cửa sổ thao tác. Ngoài ra, 

người sử dụng có thể chép (Copy), sửa chửa (Edit) và thực thi các lệnh trước. 
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Để vào Minitab for Windows, ta nhấp chuột 2 lần vào dấu Minitab trên Desktop 

hoặc Start > Program > MINITAB …. for Windows > MINITAB. Màn hình chính 

của Minitab gồm các phần: Menu Bar, Standard Toolbar, Project Manager Toolbar, 

Title Session Window, Data Window, Status Bar. 

Session Window giúp tạo chương trình bằng cách gõ các câu lệnh. Thông thường 

các lệnh và kết quả sẽ được thể hiện trên cửa sổ này khi thực thi. 

Data Window cho phép bạn nhập dữ liệu vào bảng tính bằng cách gõ hoặc xuất 

nhập các file dữ liệu từ bên ngoài. 

Đồ thị khi thực thi các lệnh của Minitab có yêu cầu vẽ đồ thị, Minitab tự động mở 

một cửa sổ chứa đồ thị yêu cầu. Lưu ý, Minitab chỉ cho hiển thị tối đa 15 đồ thị trên 

cùng một project. 

Menu bar giúp mở các Menu và chọn các câu lệnh, nhấp chuột vào các mục trên 

thanh menu sau đó nhấp chuột vào các mục phụ thuộc để thực hiện lệnh hoặc mở hộp 

hội thoại. Khi các chức năng này không sử dụng được các hạng mục sẽ mờ đi. Để thực 

hiện lệnh như trên, tập tài liệu này sẽ ghi vắn tắt Start > Tables > Cross Tabulation có 

nghĩa là chọn Start trên thanh menu, chỉ vào Tables và chọn Cross Tabulation trên 

Submenu của Tables. 

Menu Edit, Manip, Editor, Star và Graph hỗ trợ những lựa chọn để xử lý dữ 

liệu trong Minitab. Menu Edit của Minitab cũng giống như hầu hết các ứng dụng khác 

trên Windows gồm các chức năng như chép (copy), dán (Paste), xóa (Delete) và chọn 

lựa (Select). Menu Manip chứa các lệnh xử lý trong Minitab. Menu Editor chứa các 

chức năng chuyển dịch và định dạng bảng tính đặc thù của Minitab. Menu Start cung 

cấp một số công cụ để phân tích thống kê. Menu Graph hỗ trợ các công cụ để vẽ các 

loại đồ thị khác nhau. 
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Phần Display ở hình trên cho phép người dùng chọn những thông số được thể hiện 

trong kết quả của thao tác. Các nút lệnh cho phép người dùng bổ sung một số lựa chọn 

đặc thù của loại dữ liệu vào kết quả lệnh. 

Session: Dùng danh mục này để sao chép, xóa hoặc in kết quả và các đồ thị từ 

Session Window. Bạn có thể bổ sung nội dung của Session Window vào ReportPad. 

History: Danh mục này chứa tất cả lệnh được dùng trong suốt phiên làm việc. 

Dùng danh mục này để lặp lại các thứ tự lệnh hoặc tạo các Macro. 

Chart: Dùng danh mục này để quản lý tất cả các đồ thị. Bạn có thể xóa, sắp đặt 

hoặc bổ sung đồ thị vào ReportPad. 

Worksheet: Dùng danh mục này cho các thông tin danh worksheet bao gồm cột, 

các biến cố định, số cột, các giá trị thiếu và ma trận. 

Các lệnh của Minitab có sẵn trong Menu hoặc thông qua ngôn ngữ trong phần 

Session Window. Ở đây, chúng ta chỉ tập trung vào sử dụng các lệnh trên thanh Menu. 

1.2 MINITAB WINDOWS 

Đối với Minitab, dữ liệu đầu vào có thể nhận được thông qua nhập liệu trực tiếp 

vào các cửa sổ bảng tính (Worksheets) hoặc lấy file dữ liệu cuả Minitab hoặc từ các ứng 

dụng bảng tính khác như Excel... Kết quả phân tích của Minitab là kết quả bằng số,  

chữ và hình ảnh đồ thị thông qua các cửa sổ của Minitab. 
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1.3 BẢNG TÍNH MINITAB (MINITAB WORKSHEET) 

1.3.1 Dữ liệu Minitab 

Bảng tính của Minitab gồm các hàng (Row) và cột (Column). Thông thường, các 

cột dành cho các biến. Các giá trị quan sát của mỗi biến hoặc điểm dữ liệu sẽ được điền 

vào mỗi ô (cell) trên hàng. Các cột được thể hiện bằng C1, C2, C3,… và các hàng trong 

từng cột sẽ được đánh số 1, 2, 3, hàng đầu tiên dành riêng cho tên của cột. 

Trong phiên bản Minitab 13, mỗi bảng tính cho phép dùng đến 4000 cột. Số lượng 

hàng và ô phụ thuộc vào phân bổ bộ nhớ. Bạn có thể tự kiểm soát được công việc này 

bằng cách chọn Edit > Preference > General. 

1.3.2 Dữ liệu thiếu (Missing data) 

Nhiều tập dữ liệu thiếu một số giá trị và quan sát, trong trường hợp này, khi nhập 

liệu bạn gõ dấu (*) vào nơi có giá trị thiếu. Các lệnh của Minitab sẽ tự động tính đến giá 

trị (*) này khi phân tích. Nếu khi thực hiện một phép tính mà Minitab không thể thực 

hiện được như lấy căn của một số âm... Minitab sẽ tự động cho ra giá trị (*). 

1.3.3 Nhập dữ liệu 

Minitab hỗ trợ nhiều cách để nhập liệu vào bảng tính. Có thể nhập trực tiếp dữ liệu 

vào Session Windows, mở một file mới, dán dữ liệu vào bộ nhớ... Để nhập dữ liệu, chỉ 

cần hiển thị ô bằng cách dùng mũi tên, nhấp chuột và nhập dữ liệu. 

Nhập dữ liệu trực tiếp: Minitab nhận dữ liệu dạng bảng số liệu gõ trực tiếp trong 

Worksheet, hoặc nhập liệu từ Session windows. 

Nhập liệu từ file có sẵn: Minitad có thể truy xuất file dữ liệu có sẵn của chính 

Minitad như các file có phần mở rộng dạng .MTW hay .MTP, hoặc mở file dữ liệu 

của ứng dụng khác như Excel bằng lệnh File>Open Worksheet> và chọn file dữ liệu 

muốn mở. 

Dữ liệu của Minitab cũng được lưu trong file project. Nếu file dữ liệu là dạng 

project, để truy xuất file này là File> Open project> và chọn file muốn mở. Nếu như 

bạn mở project bằng Worksheet hay ngược lại, dữ liệu sẽ không xuất hiện. 

Số liệu được nhập vào cột trong Windows Worksheet  

Thay thế dấu phẩy (,) bằng dấu chấm (.) trong phần thập phân. Ô số liệu khuyết 

được thay thế bằng dấu sao (*), không được để trống. Cột số liệu phải ở dưới dạng số. 

Đối với một chỉ tiêu nghiên cứu, số liệu được nhập dưới dạng cột. Tên cột số liệu luôn 

nằm ở trên hàng thứ 1. 
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Descriptive Statistics: KL  

 
Variable  N  N*    Mean  SE Mean  StDev  Minimum      Q1  Median      Q3 
KL        7   0  15.257    0.741  1.960   12.400  12.900  15.400  17.100 
 
Variable  Maximum 
KL         17.500 

 

1.3.4 Sửa chữa nội dung  

Khi nhập liệu bạn cần phải đọc kỹ lại những giá trị và tên biến, nếu như bạn ghi 

sai thì bạn cần phải sửa chữa nội dung của từng ô dữ liệu bằng cách xóa, ghi lại, chèn 

thêm bằng các thao tác chuột hoặc bàn phím trước khi thực hiện phân tích. Bạn có thể 

sử dụng lệnh Undo của Minitab để khôi phục lại việc làm trước bằng cách dùng Menu 

hoặc click và icon… trên thanh lệnh. 

1.3.5 Đặt tên cột 

Bạn có thể đặt tên cột bằng tiêu đề của cột (C1) hoặc đặt tên riêng vì bạn có thể 

nhớ tên của dữ liệu dễ hơn số cột. Khi sử dụng các phần mềm xử lý dữ liệu, việc sử 

dụng tiếng Việt sẽ là một hạn chế, một số chương trình không sử dụng font hỗ trợ.  

Vì vậy, đối với các dữ liệu, để thuận tiện việc tham chiếu và xử lý số liệu, các bạn có 

thể dùng tiếng Anh, ký hiệu hoặc tiếng Việt không dấu. 
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Khi đặt tên cột hoặc tên biến bạn nên đặt ngắn gọn, thể hiện được đặc tính của 

biến và tránh lầm lẫn với các biến khác. Biến có quá nhiều ký tự sẽ gây khó khăn khi 

thực hiện các phép tính. Bạn đặt tên cột ngắn gọn, không nên dùng các ký tự đặc biệt 

(:, /…) hoặc các ký tự tiếng Việt (ô, ă…). Trong cùng một Worksheet không đặt tên cột 

trùng nhau. Phần mềm Minitab không phân biệt được các ký tự viết hoa và viết thường 

(ví dụ: MINITAB = Minitab = Minitab). 

1.3.6 Đặt tên bảng tính 

Trong một project, bạn có thể có nhiều Worksheet, có thể đặt tên cho Worksheet 

để dễ kiểm soát và tham khảo. Nếu bạn không đặt tên thì Minitab mặc định đặt theo thứ 

tự Worksheet 1 hoặc Worksheet 2. Để đặt tên, bạn nên chọn Window>Manage 

worksheets Chọn Worksheet 1 trong hộp Worksheet, chọn nút rename và gõ tên bạn 

mong muốn >OK, >Done. Sau khi đã đặt tên cho Worksheet, tên này sẽ xuất hiện trên 

thanh tiêu đề.  

1.4 THỰC HIỆN TÍNH TOÁN VÀ TRUY SUẤT KẾT QUẢ THỐNG KÊ TỪ 

 MINITAB 

1.4.1 Các phép tính đơn giản 

Có thể thực hiện các phép tính đơn giản bằng lệnh Manip>calculator. Màn hình 

lệnh này thể hiện lệnh yêu cầu nhập ô kết quả Store result in Variable. Kết quả này sẽ 

được lưu vào ô cột trên Data window của Minitab. Công thức tính được nhập vào phần 

Expression, bạn có thể dùng các hàm có sẵn của Minitab trong phần Fuctions hoặc các 

chức năng hiện trên lựa chọn này để tính toán. 
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1.4.2 Xuất kết quả thống kê vào Session window 

Có thể dùng lệnh Stat>Basic statistics> Display Descriptive Statistics để xuất 

kết quả thống kê của tập dữ liệu, kết quả này sẽ thể hiện trong phần Session Window. 

1.5 CÁC ĐỒ THỊ MINITAB 

Hầu hết các kết quả đồ thị của Minitab đều được thể hiện dưới dạng đồ thị chuyên 

dùng. Tuy nhiên, tốt hơn nên vẽ từ phần mềm Excel hoặc Power Point. 

1.6 QUẢN LÝ DỮ LIỆU 

1.6.1 File dữ liệu của Minitab 

Dữ liệu của Minitab gồm các nhóm chính: Project files, Worksheet files, Session 

window files (chữ) và Graphic files. Bảng 1.2 phân loại các loại file dữ liệu của Minitab. 

Có thể mở (Open), tạo mới (New), lưu (Save) các loại file này trên Menu file. Project 

files sẽ bao gồm tất cả các loại dữ liệu có trong Project, bao gồm các Worksheet, Session 

window, các đồ thị đã có trong project. Các dạng file còn lại chỉ lưu kết quả của dạng 

dữ liệu mặc định của nó. 

1.6.2 Truy xuất dữ liệu từ các ứng dụng khác 

Minitab lưu dữ liệu dưới nhiều dạng tùy vào chức năng và yêu cầu. Tuy nhiên,  

bạn có thể nhập dữ liệu từ các file dữ liệu bên ngoài từ MS Word, MS Excel hoặc các 

file dữ liệu Minitab khác bằng câu lệnh File > Open worksheet và tìm đúng loại file 

trong hộp thoại List Files of Type, chọn file dữ liệu bạn muốn mở. 

1.6.3 Xử lý tập dữ liệu 

Gộp và tách dữ liệu (Stacking and Unstacking data): Trong Minitab, thông 

thường một cột chỉ chứa dữ liệu của một biến với mỗi quan sát trong mỗi hang hoặc 

điểm dữ liệu trong từng ô gọi là Unstacked data. Dữ liệu có thể ở dạng stacked nếu như 

các điểm dữ liệu thuộc nhiều nhóm dữ liệu. 

1.7 CÁC CÔNG DỤNG IN TRONG MINITAB 

Để in các công việc, dữ liệu, đồ thị, báo cáo…, bạn dùng câu lệnh trên thanh 

File>Print có thể chọn những lựa chọn khác nhau cho chức năng in như trong hình dưới 

đây. Chúng ta cũng có thể chọn sao chép dữ liệu hoặc kết quả sang một phần mềm xử 

lý văn bản khác (như MS Word) để in ra. 


